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CSI Pro Quick Start Installation

Guide

TradingView | TradeStation | MetaTrader 5

Welcome to CSI Pro - Confluence Signal Intelligence. You now have

access to a professional-grade trading system built on advanced multi-factor

analysis. This guide covers installation for all three supported platforms.

Installation is quick and easy — most users complete setup in under 5

minutes. Just find your platform section below and follow the steps. If

anything is unclear, our AI assistant can walk you through it.

New to your platform? If you're unfamiliar with adding indicators or

navigating charts, refer to your platform's documentation for guidance

(TradingView, TradeStation, or MT5 each have help centers), then return here.



⚠ Your First Stop for Help: 24/7 AI Assistant

Before emailing support, try our instant AI chatbot - it can answer most

questions immediately!

Visit now: https://frontieralgo.com/csi/support.html

Get instant answers to installation questions, indicator settings, and signal

interpretation

The AI assistant walks you through each step in real-time

Available 24/7 - no waiting for email responses

Ask anything - from basic setup to advanced trading questions

This guide covers all three platforms comprehensively, but you only need to read your

platform section. The AI assistant can clarify anything that seems unclear.

Support Resources

AI Chatbot (Recommended First): https://frontieralgo.com/csi/support.html - Instant

answers 24/7

Email support: support@frontieralgo.com (response within 24 hours)

Important: This guide explains how to install and access CSI Pro, an analytical tool. Nothing contained herein

constitutes investment advice, trading recommendations, or solicitation to buy or sell any financial

instrument. CSI Pro is not a registered investment advisor, broker-dealer, or financial planner. All trading

involves substantial risk of loss; only trade with capital you can afford to lose. Past indicator performance does

not guarantee future results. You are solely responsible for your own trading decisions. By using CSI Pro, you

acknowledge and accept these terms. Read Full Disclaimer →

1 TRADINGVIEW

How TradingView Access Works

CSI Pro indicators on TradingView are "invite-only scripts." This means we

manually grant your TradingView account access to view and use them. You

https://frontieralgo.com/csi/support.html
https://frontieralgo.com/csi/support.html
mailto:support@frontieralgo.com
https://frontieralgo.com/disclaimers.html


must submit your TradingView username through our unlock page for this

to happen.

⚠ Before You Start: Verify Your Access Was Requested

After your purchase, you should have been redirected to our unlock page to submit

your TradingView username.

Did you complete the username submission form?

YES, I submitted my username: Access is typically granted within 24 hours.

Continue to "Step 1" below.

NO, I didn't see a form / I'm not sure: Go to

https://frontieralgo.com/csi/unlock_code.html NOW and submit your

TradingView username.

? How to Find Your TradingView Username

Your username is NOT your email address. Here's how to find it:

1. Log in to TradingView.com

2. Click your profile icon in the top right corner of the page

3. Your username is displayed at the top of the dropdown menu

4. It typically looks like: @YourUsername  (without the @ symbol when

submitting)

Your username can also be found in your profile URL:

tradingview.com/u/YourUsername

https://frontieralgo.com/csi/unlock_code.html


1 Check If You Have Access

Before proceeding with installation, verify your access has been

granted:

1. Log into TradingView.com

2. Open any chart (the symbol doesn't matter)

3. Click the "Indicators" button at the top of your chart, OR press

the /  key

4. In the left sidebar of the Indicators window, look for the "Invite-

only scripts" tab

5. Click on that tab

✓ If You See CSI Indicators Listed:

⚠ If the Tab is Empty or CSI is Not Listed:

Your access hasn't been granted yet. See the "What If You Don't Have

Access?" section below.

You should see "Confluence Regime Intelligence

PRO+ [CRI-Pro]" and "CRI-Pro+ Confluence Pane

[CEI+CRG]"

•

You have access! Continue to Step 2 to add them to

your chart

•



2 Add Both Indicators to Your Chart

Once you can see the indicators in your Invite-only scripts tab:

Indicator Name What It Does

Confluence Regime Intelligence

PRO+ [CRI-Pro]

Main chart overlay - signals,

trends, dashboard

CRI-Pro+ Confluence Pane

[CEI+CRG]

Oscillator panel - CEI and CRG

gauges

Click each indicator name once to add it to your chart. Both

indicators will load automatically.

3 Verify Installation

✓ Installation Confirmed - Verify These Elements:

+ Customize Settings (Optional)

To adjust parameters, click the gear icon next to the indicator name

in the chart legend.

Note: CSI Pro works with FREE TradingView accounts. No paid

TradingView subscription is required.

Main chart: CSI-Pro+ displaying signal arrows and

information dashboard

•

Lower pane: Confluence Pane showing CEI and PRG

oscillators

•



⚠ TradingView Troubleshooting

"I don't see the Invite-only scripts tab at all"

The tab only appears if you have at least one invite-only indicator. If you've never had

access to any invite-only scripts before:

1. Confirm you submitted your username at

https://frontieralgo.com/csi/unlock_code.html

2. Wait up to 24 hours for access to be granted

3. After 24 hours, try logging out of TradingView and back in

4. Clear your browser cache if the tab still doesn't appear

"I see the Invite-only scripts tab, but CSI Pro isn't listed"

This means your access hasn't been granted yet, or there may be a username

mismatch.

1. Less than 24 hours since purchase? Wait - access is granted manually during

business hours

2. More than 24 hours? Double-check that you submitted your username correctly

at https://frontieralgo.com/csi/unlock_code.html

3. Still no access? Email support@frontieralgo.com with:

Your exact TradingView username

Your order confirmation or receipt

The email address used for purchase

"The indicator loads but shows no signals"

Make sure your chart has at least 200 bars of data loaded

Try a larger timeframe (like 1-hour or daily) to confirm it's working

Some symbols with limited data may not display properly

Scroll to the current bar - the dashboard appears near recent price action

"I have a free TradingView account - will this work?"

https://frontieralgo.com/csi/unlock_code.html
https://frontieralgo.com/csi/unlock_code.html
mailto:support@frontieralgo.com


Yes! CSI Pro is fully compatible with free TradingView accounts. No paid TradingView

subscription is required.

Need More Help?

Try the AI chatbot first: https://frontieralgo.com/csi/support.html -

Get instant answers 24/7

Email: support@frontieralgo.com

Next Steps

Review the CSI_PRO_COMPLETE_MANUAL_TradingView_Version.pdf for complete

documentation on signals, settings, and trading strategies.

2 TRADESTATION

How TradeStation Access Works

TradeStation indicators are delivered as an ELD file customized with your

Customer Number. After you submit your Customer Number through our unlock

page, we generate and email your personalized indicator file.

⚠ Before You Start: Verify You Have Your ELD File

You should have received an email with your personalized

CSI_CONFLUENCE_SIGNAL_INTELLIGENCE.ELD file attached.

YES, I have the ELD file: Continue to the installation steps below.

NO, I haven't received the email: Check your spam/junk folder. If still not there,

go to https://frontieralgo.com/csi/unlock_code.html and submit your

TradeStation Customer Number.

https://frontieralgo.com/csi/support.html
mailto:support@frontieralgo.com
https://frontieralgo.com/csi/unlock_code.html


? How to Find Your TradeStation Customer Number

Your Customer Number is required to generate your personalized

indicator file. Here's how to find it:

1. Open TradeStation

2. Click Help in the top menu

3. Click About TradeStation

4. Your Customer Number is displayed in that window

The Customer Number is a numeric code that uniquely identifies your

TradeStation account.

Your Personalized Package Contains:

CSI_Pro_ShowMe - Main chart overlay with signals

CSI_Pro_PRG - Probability Reversal Gauge

CSI_Pro_CEI - Cycle Exhaustion Index

! Quick Install: Double-Click Method

Recommended approach:

1. Locate CSI_CONFLUENCE_SIGNAL_INTELLIGENCE.ELD  in your Downloads

folder (from the email)

2. Double-click the file

TradeStation will launch automatically and open the Import Wizard.



1 The Import Wizard Opens

After double-clicking, the EasyLanguage Import Wizard will appear.

Click Next to continue.

2 Verify All Components Are Selected

You should see checkboxes for three items:

CSI_Pro_ShowMe

CSI_Pro_PRG

CSI_Pro_CEI

Make sure all three are checked, then click Next.

3 Handle Any Replacement Prompts

If you've installed a previous version, TradeStation will ask if you

want to replace it.

Click Yes to All to update to the latest version.



4 Complete the Installation

Click Finish.

TradeStation will automatically compile the indicators.

✓ Installation Complete

? Alternative Method: Manual Import

If double-clicking doesn't launch the wizard, follow these steps:

1. Open TradeStation

2. Go to File > Import/Export EasyLanguage

3. Select Import EasyLanguage (ELD, ELS or ELA)

4. Click Browse and navigate to your

CSI_CONFLUENCE_SIGNAL_INTELLIGENCE.ELD file

5. Click Open, then Next

6. Verify all three components are checked

7. Click Next, then Finish

Indicators are now installed and ready for use•



5 Verify Installation

To confirm everything installed correctly:

1. Go to View > EasyLanguage Documents

2. Look under ShowMe Studies - you should see CSI_Pro_ShowMe

3. Look under Indicators - you should see CSI_Pro_PRG and

CSI_Pro_CEI

+ Workspace Installation (If Included)

If you received a workspace file (.tsw):

1. Complete the ELD installation first

2. Double-click the .tsw file

3. TradeStation will open with pre-configured charts



⚠ TradeStation Troubleshooting

"I never received my ELD file email"

1. Check spam/junk folder - emails from frontieralgo.com sometimes get filtered

2. Wait up to 24 hours - files are generated and sent manually during business

hours

3. Submit your Customer Number at https://frontieralgo.com/csi/unlock_code.html

if you haven't already

4. Contact support at support@frontieralgo.com with your Customer Number and

order confirmation

"Analysis technique not found" error when opening workspace

This means the workspace is trying to use indicators that aren't installed yet.

Solution: Install the ELD file FIRST, then open the workspace file.

"Double-clicking the ELD file does nothing"

1. Make sure TradeStation is installed and working

2. Try the Manual Import method described above

3. Right-click the ELD file > Open With > TradeStation

"Components don't appear in EasyLanguage Documents"

1. Re-import the ELD file using the manual method

2. When prompted about existing versions, click Replace or Yes to All

3. Restart TradeStation after import

https://frontieralgo.com/csi/unlock_code.html
mailto:support@frontieralgo.com


Need More Help?

Try the AI chatbot first: https://frontieralgo.com/csi/support.html -

Get instant answers 24/7

Email: support@frontieralgo.com

Next Steps

Review the CSI_PRO_COMPLETE_MANUAL_TradeStation_Version.pdf for complete

documentation on signals, settings, and trading strategies.

3 METATRADER 5

How MetaTrader 5 Access Works

MT5 indicators are delivered as compiled .ex5 files customized for your MT5

account. After you submit your MT5 Account Number through our unlock page,

we generate and email your personalized indicator files.

⚠ Before You Start: Verify You Have Your Indicator Files

You should have received an email with your indicator files (.ex5 files) attached or as a

download link.

YES, I have the .ex5 files: Continue to the installation steps below.

NO, I haven't received the email: Check your spam/junk folder. If still not there,

go to https://frontieralgo.com/csi/unlock_code.html and submit your MT5

Account Number.

https://frontieralgo.com/csi/support.html
mailto:support@frontieralgo.com
https://frontieralgo.com/csi/unlock_code.html


? How to Find Your MT5 Account Number

Your MT5 Account Number (also called Login number) is required to

generate your personalized indicator files. Here's how to find it:

1. Open MetaTrader 5

2. Look at the Navigator panel on the left side (press Ctrl+N if not

visible)

3. Expand Accounts - your account number is shown next to your

broker name

4. Alternatively: Click File > Login to Trade Account - the number

in the "Login" field is your account number

Your account number is typically a 6-10 digit number.

Included Files

Your package contains three indicator files:

File Purpose

CSI_Pro.ex5 Main signal generator with on-chart dashboard

CSI_Pro_PRG.ex5 Probability Reversal Gauge oscillator

CSI_Pro_CEI.ex5 Cycle Exhaustion Index oscillator



1 Open Your Data Folder

1. Launch MetaTrader 5

2. Click File in the top menu

3. Click Open Data Folder

A Windows Explorer window will open showing your MT5 data

location.

2 Navigate to the Indicators Folder

In the folder that opened:

1. Double-click MQL5

2. Double-click Indicators

You are now in the correct folder for custom indicators.

3 Copy Your Indicator Files

1. Locate the three .ex5 files  you received (check your Downloads

folder or extract from ZIP)

2. Copy all three files

3. Paste them into the Indicators folder you just opened



4 Refresh MetaTrader

Back in MetaTrader 5:

1. Press Ctrl+N  to open the Navigator panel (or click View >

Navigator)

2. Find Indicators in the Navigator tree

3. Right-click on Indicators

4. Click Refresh

Your indicators will now appear in the list.

5 Add Indicators to Your Chart

In the Navigator panel, locate the CSI indicators and double-click

each one to apply to your chart.

Recommended Setup:

Location Indicator What You'll See

Main Chart CSI_Pro
Signal arrows, trend lines,

dashboard

Subwindow

1
CSI_Pro_CEI Cycle exhaustion analysis

Subwindow

2
CSI_Pro_PRG Probability reversal gauge



6 Verify Installation

Check the Experts tab at the bottom of MT5. Confirmation

messages indicate each indicator loaded successfully.

✓ Installation Confirmed - Verify These Elements:

CSI Pro displayed in the chart title•

Dashboard panel showing trade information•

Subwindows displaying CEI and PRG oscillators•



⚠ MetaTrader 5 Troubleshooting

"I never received my indicator files email"

1. Check spam/junk folder - emails from frontieralgo.com sometimes get filtered

2. Wait up to 24 hours - files are generated and sent manually during business

hours

3. Submit your MT5 Account Number at

https://frontieralgo.com/csi/unlock_code.html if you haven't already

4. Contact support at support@frontieralgo.com with your Account Number and

order confirmation

"The indicators don't appear in Navigator after refresh"

1. Verify file location: The .ex5 files must be directly in MQL5/Indicators (not in a

subfolder)

2. Check file extension: Make sure files are .ex5, not .ex5.txt or similar

3. Restart MT5: Sometimes a full restart is needed for new indicators

"I get a DLL error or the indicator won't load"

1. Open Tools > Options > Expert Advisors tab

2. Make sure "Allow DLL imports" is checked

3. Click OK and try adding the indicator again

"The dashboard isn't visible on my chart"

1. Open indicator settings (right-click indicator name > Properties)

2. Find "Show Dashboard" and ensure it's set to true

3. Scroll your chart to the rightmost bar - the dashboard appears in the visible area

4. Try maximizing your chart window

"Indicators load but show no signals"

1. Ensure you have sufficient historical data loaded

https://frontieralgo.com/csi/unlock_code.html
mailto:support@frontieralgo.com


2. Try a more liquid symbol like EURUSD or US30

3. Check that "Allow DLL imports" is enabled if prompted

Need More Help?

Try the AI chatbot first: https://frontieralgo.com/csi/support.html -

Get instant answers 24/7

Email: support@frontieralgo.com

Next Steps

Review the CSI_PRO_COMPLETE_MANUAL_MetaTrader5_Version.pdf for complete

documentation on signals, settings, and trading strategies.

Quick Fixes for Common Issues

If This Happens... Try This First

Access not granted (TradingView)
Submit username at

frontieralgo.com/csi/unlock_code.html

Never received files

(TradeStation/MT5)

Check spam folder; submit account number

at unlock page

Indicators not showing signals Load more historical data on your chart

Dashboard or panel not visible
Scroll chart to current bar; check display

settings

General Troubleshooting

https://frontieralgo.com/csi/support.html
mailto:support@frontieralgo.com
https://frontieralgo.com/csi/unlock_code.html


If This Happens... Try This First

Installation seems stuck Restart your trading platform completely

File won't open or import
Re-download the file; check for antivirus

blocking

⚠ Access Delivery Timeline

Platform How Access is Delivered
Typical

Timeline

TradingView
We manually add your username to our

invite-only scripts

Within 24

hours

TradeStation Personalized ELD file emailed to you
Within 24

hours

MetaTrader

5
Personalized .ex5 files emailed to you

Within 24

hours

Important: Access is granted manually during business hours. If you purchased on a

weekend or holiday, your access may arrive the next business day.



Still Having Issues?

Start with our AI chatbot: https://frontieralgo.com/csi/support.html

The AI assistant resolves most questions instantly and is available 24/7.

Email: support@frontieralgo.com

When contacting email support, please include:

Your platform (TradingView, TradeStation, or MT5)

Your username or account number

Your order confirmation or receipt

A description of the issue

Installation Complete

CSI - Confluence Signal Intelligence is now ready for use.

Explore the indicator settings and review the complete manual for your platform to

maximize the system's capabilities.

Welcome to FrontierAlgo.

CSI - Confluence Signal Intelligence | FrontierAlgo.com

https://frontieralgo.com/csi/support.html
mailto:support@frontieralgo.com

